Monday, December 27, 2010

Update to ATV2 problem - Fixed

After a few more hours of troubleshooting and reading I found there is a feature in DNSMasq that protects you from a DNS Rebind attack.  Unfortunately, the way Netflix works it uses something that looks just like that, so your DNS queries don't work and you get no video.

With most setups you could change the DNS server of your Apple TV (and iPhones, because this happens on them also) to the google address (  Of you can look at your router to see what your ISPs DNS server is and use that.

If you are using DD-WRT, you can upgrade (or look, you might already have this feature if you upgraded in the last 2 months) to a version that has "No DNS Rebind" on the services page in the DNSMasq section.  This turns off that security feature.  Below is a picture with it turned off.  Be sure to reboot your router after you make this change.

If you are using DNSMasq on something else, look into a way to turn off DNS Rebind protection.  There are several commands out there for Linux based systems, but I don't have the time to go check them.  You can start at this link that has some of the commands: 

Sunday, December 26, 2010

Apple TV 2 problems

I've been working on the "no netflix videos" for a few days now, and finally tried something new and got it working.  Prior to this I could browse everything, but trying to play would spin the pinwheel, and then go back to the movie description window.  Now everything works great and I can stream movies and TV shows from Netflix.

Here is what I did.
1.  I connected my ATV2 directly to the back of my cable modem.  This worked.
Going with the idea that maybe there is a connection that is being started from Netflix I decided to try normal port forwarding things on the router.
2.  I setup UPNP.  That didn't work.
3.  I setup a DMZ (basically it port forwards all incoming new connections) to the ATV2.  That didn't work either.

My final setup now until Apple/Netflix/Me figure out what's wrong and fix it is the following:
I used an old Ethernet switch, and have the these thigns connected to it:
1.  Cable modem
2.  Linksys E3000 - WAN Port (my main Internet router for my house with lots of stuff behind it)
3.  ATV2 Ethernet port

The big difference in this setup is that the ATV2 has a public Internet address as opposed to a private address.  If you have more than one Internet device in your house, you are probably using private addressing.  Your ATV probably has an address that starts with 192.168.x.x where x any number between 1 and 254.